Degraded Performance
Incident Report for XOi
Resolved
This issue has been resolved. We're seeing normal processing
Posted Dec 07, 2021 - 17:23 CST
Identified
We have identified an issue with our cloud provider that is causing degraded platform performance. You may notice blank pages on the web application as well as delays processing.

We'll update once further details are available or the issue is resolved.
Posted Dec 07, 2021 - 09:55 CST
This incident affected: Vision (Web, Mobile).